aboutsummaryrefslogtreecommitdiff
path: root/shell.nix
diff options
context:
space:
mode:
authorLinnea Gräf <nea@nea.moe>2024-03-15 11:37:42 +0100
committerLinnea Gräf <nea@nea.moe>2024-03-15 11:38:16 +0100
commit3a0ff1900047f21b420fc9c02d67dc0f04a4fd0c (patch)
tree83783bcb2dd985ae5b953b835771b9e96ba0325f /shell.nix
parent4bf53dcaf18dcc1fb7b064f482b2e8922d9d326f (diff)
downloadfirmament-3a0ff1900047f21b420fc9c02d67dc0f04a4fd0c.tar.gz
firmament-3a0ff1900047f21b420fc9c02d67dc0f04a4fd0c.tar.bz2
firmament-3a0ff1900047f21b420fc9c02d67dc0f04a4fd0c.zip
Add shell nix
[no changelog]
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix15
1 files changed, 15 insertions, 0 deletions
diff --git a/shell.nix b/shell.nix
new file mode 100644
index 0000000..330a57a
--- /dev/null
+++ b/shell.nix
@@ -0,0 +1,15 @@
+# SPDX-FileCopyrightText: 2023 Linnea Gräf <nea@nea.moe>
+#
+# SPDX-License-Identifier: GPL-3.0-or-later
+{pkgs ? import <nixpkgs> {}}:
+pkgs.mkShell {
+ buildInputs = with pkgs; [
+ bash
+ gh
+ git
+ xdg-utils
+ temurin-bin-17
+ reuse
+ pre-commit
+ ];
+}