Age | Commit message (Collapse) | Author |
|
|
|
|
|
|
|
|
|
|
|
|
|
Co-authored-by: hannibal2 <24389977+hannibal00212@users.noreply.github.com>
|
|
Co-authored-by: hannibal2 <24389977+hannibal00212@users.noreply.github.com>
|
|
* ughidontwannafigureouthowtousethis
* not finished
hgdt<
* Make use of new collections api in collectionspage
* final commit HOPEFULLY
* fix infer v1
* fix mithril powder going over cap
my beloved
* Formatting :thumbsup:
* More Formatting :thumbsup:
important
* ea sports
its in the game
* maybe fix cache
* change location of weight and networth and config option for weght
requested by alea
* Fix jump at CAP powder
* Code formatting and deleted unused variables.
* Used KUUDRA_TIERS array from CrimsonIslePage in SlayingTaskLevel.
* Used SLAYERS array from PROFILEVIEWER in SlayingTaskLevel.
* Intellij Code Cleanup.
* revert fun things
Please efe put formatting in another PR.
* fix issues
idk
* Import fixes and formatting. And an unnecessary empty space in 2.1.1 for jani.
* fix nea issue
---------
Co-authored-by: nea <nea@nea.moe>
Co-authored-by: jani270 <jani270@gmx.de>
Co-authored-by: hannibal2 <24389977+hannibal00212@users.noreply.github.com>
|
|
* Add EnforcedConfigValues: Allow disabling options via the repo
* EnforcedConfigValues: Allow filtering for mod version
* nitpicking
|
|
Co-authored-by: hannibal2 <24389977+hannibal00212@users.noreply.github.com>
|
|
Co-authored-by: hannibal2 <24389977+hannibal00212@users.noreply.github.com>
|
|
Co-authored-by: Vixid <52578495+vixid1@users.noreply.github.com>
Fixes https://github.com/NotEnoughUpdates/NotEnoughUpdates/issues/471
|
|
Co-authored-by: Vixid <52578495+Vixid1@users.noreply.github.com>
|
|
|
|
|
|
* Fixed double register of view uses or recipes
* !
|
|
Prevent recipe hotkeys (R + U) when inside the experimentation table.
Co-authored-by: hannibal2 <24389977+hannibal00212@users.noreply.github.com>
|
|
|
|
Co-authored-by: Lulonaut <lulonaut@tutanota.de>
Co-authored-by: Roman / Linnea Gräf <roman.graef@gmail.com>
|
|
|
|
Co-authored-by: hannibal2 <24389977+hannibal00212@users.noreply.github.com>
|
|
|
|
Co-authored-by: hannibal2 <24389977+hannibal00212@users.noreply.github.com>
Fixes https://github.com/NotEnoughUpdates/NotEnoughUpdates/issues/560
|
|
|
|
|
|
Co-authored-by: nea <romangraef@gmail.com>
Co-authored-by: Lulonaut <lulonaut@tutanota.de>
|
|
|
|
|
|
add tooltip resizing
|
|
* Added kuudra party join message clickable support.
* Typo.
Co-authored-by: hannibal2 <24389977+hannibal00212@users.noreply.github.com>
|
|
Co-authored-by: hannibal2 <24389977+hannibal00212@users.noreply.github.com>
|
|
prevent offline pv crashes
Co-authored-by: hannibal2 <24389977+hannibal00212@users.noreply.github.com>
|
|
|
|
|
|
|
|
|
|
|
|
|
|
* add button to toggle search mode
* Its a bit better
Co-authored-by: jani270 <jani270@gmx.de>
|
|
|
|
* Hotkeys for wardrobe slots, e.g when in the wardrobe, pressing 1 will select the first wardrobe slot
* fix wardrobe keybinds not updating
* fix up some stuff
* i suppose
* I should learn more kotlin
* considered
|
|
* This feature allows players to view the profile of another player who has joined their dungeon group through the party finder by hovering and clicking on the chat message announcing the player's arrival.
* regex on top
* Constants stay upper the case.
Co-authored-by: hannibal2 <24389977+hannibal00212@users.noreply.github.com>
|
|
* Remove Unused Import "org.luaj.vm2.ast.Str"
Add final keyword in various places, creating slight performance increases
* Refactoring, Error Prevention, and Duplicate Code Simplification
Rename "stats" declared in line 1723 to "playerStats" to avoid hiding the "stats" field declared at line 648.
Rename "passiveStats" declared in line 1723 to "passivePlayerStats" to avoid hiding the "passiveStats" field declared at line 649.
Rename "networth" declared in line 939 to "playerNetworth" to avoid hiding the "networth" field declared at line 650.
Rename "networth" declared in line 910 to "soopyNetworthData" to avoid hiding the "networth" field declared at line 650.
soopyNetworthData
Change if check to "isEmpty" rather than size() > 0
Add function getAuctionPriceHelper to increase readability and decrease duplicate code
Replaced null with Empty Collections in some cases, to make caller logic simpler
Remove commented code for Catacombs in skilltoSkillDesiplayMap
Merge if statementes with their enclosing if statements, as they were unnecessarily nested.
* Redefine petRarityToNumMap and skillToSkillDisplayMap as ImmutableMaps rather than HashMap and LinkedHashMap respectively due to their immutable nature.
* Fix typo in SkyCrypt capilization
Add final to some variables for improved performance.
|
|
|
|
|
|
|
|
|
|
|
|
Co-authored-by: hannibal2 <24389977+hannibal00212@users.noreply.github.com>
Co-authored-by: nopo <nopotheemail@gmail.com>
|