summaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authornea <nea@nea.moe>2023-01-29 20:38:21 +0100
committernea <nea@nea.moe>2023-01-29 20:38:21 +0100
commitb9e1d23e2000cca681370cb9d215efa8c74ef52b (patch)
tree3fc15554b060ef51d26e0e50ed4f2076e416f93d /Cargo.toml
downloadmgasi-b9e1d23e2000cca681370cb9d215efa8c74ef52b.tar.gz
mgasi-b9e1d23e2000cca681370cb9d215efa8c74ef52b.tar.bz2
mgasi-b9e1d23e2000cca681370cb9d215efa8c74ef52b.zip
initial
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml31
1 files changed, 31 insertions, 0 deletions
diff --git a/Cargo.toml b/Cargo.toml
new file mode 100644
index 0000000..138f7fe
--- /dev/null
+++ b/Cargo.toml
@@ -0,0 +1,31 @@
+[package]
+name = "mgasi"
+version = "0.1.0"
+edition = "2021"
+
+# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
+
+[dependencies]
+
+[dependencies.craftio-rs]
+version = "0.1.0"
+features = ["default"]
+
+[dependencies.tokio]
+version = "1.15.0"
+features = ["full"]
+
+[dependencies.anyhow]
+version = "*"
+
+[dependencies.mcproto-rs]
+version = "*"
+
+[patch.crates-io.mcproto-rs]
+git = "https://github.com/Web-44/mcproto-rs.git"
+
+[patch.crates-io.craftio-rs]
+git = "https://github.com/romangraef/craftio-rs.git"
+branch = "fix/read_packet_len"
+
+